400 Error on Billing Page After Credit Card Validation
Incident Report for Hydrogen
Postmortem

This error was escalated to the Hydrogen support team and fixed within 2-hours of being reported. The error occurred due to some incorrect business logic for billing on the 1st day of the month. A fix was inserted into the next release to correct this going forward.

Posted Aug 02, 2021 - 10:33 EDT

Resolved
There is a 400 error being received by customers after inputting credit card information on the Hydrogen Billing/Upgrade page.
Posted Aug 01, 2021 - 19:00 EDT