Card Phone Support Not Operational
Incident Report for Hydrogen
Resolved
This incident has been resolved.
Posted Mar 23, 2022 - 11:44 EDT
Investigating
Cardholders are experiencing disconnection of calls to the card support phone number.
Posted Mar 22, 2022 - 19:47 EDT
This incident affected: Card Support Call Center.